Tunnel World of Warcraft Through SSH

On Saturday I had to take the wife to UTS library so that she could do some research for her masters thesis. With petrol prices being the way they are, and just generally the amount of time it was going to take to go home and come back, I’d decided i was going to pop into the office with my laptop, and play WoW for 2-3 hours while I waited for her. Flawless plan, really. The last time i took my personal laptop to the office, everything worked no problems and I was actually able to log onto WoW.

Well not so lucky this time :|. The IT admins had obviously blocked the WoW ports through the firewall. So after a bit of Googling and reading, I came across this article which clearly explains How To Tunnel WoW Through an SSH VPN Using Only Linux and PuTTY.

It was so awesome, it worked straight off the bat, no extra tweaking, I just had to blog about it. My only gripe would be that the latency was too high for me to do any instancing (i had about 800ms latency at best, and 3000 at worst). But that’s a combination of the fact that my company doesn’t want to pay for a fast internet connection, and my Linux server runs over wireless.

5 comments

  1. hello!this guide seems to be very nice… but i´ve one problem… i dont know how-to create a loopback-adapter in my linuxsystem! (my operatingsystem: fedora 11)
    maybe you can help me? (sorry for my bad englisch, come from germany)

    thanks a lot

  2. hello xerxes,

    i´ve tried to create some loopback-devices ->
    ifconfig lo 80.239.180.112 netmask 255.255.255.252
    it seems to be ok… but is it correct?
    (Kult der Verdammten: 80.239.180.112)

    my putty-client seems to be correctly configured
    Category: SSH-> Tunnels:
    L(-ocal)127.0.0.6:3724 eu.logon.worldofwarcraft.com:3724
    L(-ocal)127.0.0.7:80 status.wow-europe.com:80
    L(-ocal)80.239.180.112 80.239.180.112

    portforwarding:
    the portforwarding is enabled (i have changed the following line -> “#AllowTcpForwarding yes” into “AllowTcpForwarding yes”) and restartet the ssh-service

    i hope.. you can help me… and sorry.. for these questions :(

  3. @r4w the loopback device needs to be setup on Windows…the client…the computer you play WoW on. if you’re playing WoW on Linux, i doubt i can help you – sorry :(

    In the instructions, under section 3.1, it says:
    “To create the loopback adapter, just follow the Add New Hardware Wizard:
    Next -> Add -> Add new -> Select from List -> Network adapters -> Microsoft -> Microsoft Loopback Adapter -> Next -> OK”

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>